Degraded performance of the Emailing Service
Incident Report for Manatal
Resolved
Our Engineering Team has implemented a fix for the issue. The application is recovered. We are currently monitoring the situation further.
Posted Nov 06, 2023 - 10:24 UTC
Investigating
We are currently experiencing a degraded performance on the Manatal emailing service. Our Engineering team is investigating with highest priority.
Posted Nov 06, 2023 - 09:58 UTC
This incident affected: Emailing.