Our Engineering Team & customer teams have confirmed the resolution of the issue.
Posted Nov 18, 2024 - 15:39 UTC
Monitoring
Our Engineering Team has identified the root cause of the partial outage & implemented a fix. The career pages are accessible again. Our team is monitoring the full resolution of the issue.
Posted Nov 18, 2024 - 15:32 UTC
Update
Our team is still investigating the issue. We will continue updating you on the progress of the investigation & Estimated Time of Resolution.
Posted Nov 18, 2024 - 15:21 UTC
Investigating
Our team has identified an issue with the Manatal-provided career pages.
Our Engineering team is working on a resolution with the highest priority. We will keep you updated in 15-minute cadences on the status of the resolution.