Our Engineering team has implemented a fix. The new career page is fully accessible again. Our team remains monitoring the situation.
Posted Jan 09, 2026 - 15:15 UTC
Identified
Our Engineering Team has identified the root cause of the partial outage & is working on a fix. Our team is working on the full resolution of the issue.
Posted Jan 09, 2026 - 14:15 UTC
Investigating
We are currently experiencing an issue with accessing the New Manatal Career Page. We are investigating this issue to identify the root cause. We will post an update here every 30 minutes until resolved.