Degraded performance of the Emailing Service

Incident Report for Manatal

Resolved

This incident has been resolved.
Posted Oct 05, 2023 - 08:14 UTC

Monitoring

Our Engineering Team has identified the root cause of the issue and implemented a fix. The Emailing Service is accessible again. Our team will further monitor the incident.
Posted Oct 05, 2023 - 08:06 UTC

Identified

We have identified an issue with the Manatal Emailing service which causes slower processing of emails. Our team is working on resolving the issue with the highest priority.
Posted Oct 05, 2023 - 07:39 UTC
This incident affected: Emailing.