Degraded performance of the Manatal Emailing Service
Incident Report for Manatal
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 12:38 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2023 - 10:38 UTC
Monitoring
Our Engineering Team has implemented a fix for the issue. The Manatal Emailing Service is recovered. We are currently monitoring the situation.
Posted Nov 21, 2023 - 10:38 UTC
Identified
Our Engineering Team has identified the root cause of the issue. We are currently implementing a fix to resolve the issue. Further updates will be provided soon.
Posted Nov 21, 2023 - 10:22 UTC
Update
Our Engineering Team is still investigating the issue. We will provide further details within the next 30 minutes.
Posted Nov 21, 2023 - 09:42 UTC
Investigating
We are currently facing degraded performance on the Manatal Emailing Service. Our Engineering team is investigating with the highest priority. Further updates will be provided soon.
Posted Nov 21, 2023 - 09:19 UTC
This incident affected: Emailing.